Jump to content


Recommended Posts


.npa Files

.npa is the archive format used by Nitro+

NIPA method

Works with most of the Nitro+ games using the . npa format :

Saya no uta Verified

cg.npa - all images

nss.npa - a bunch of .nss files. I don't know what these are.

sound.npa - all sound effects and music

voice.npa - all voice tracks

system.npa - system.ini

Link to comment
Share on other sites

  • 2 weeks later...

I'am looking for help with a "little" problem, while translate the Steins;Gate VN to german.

I'am using the official english release from JAST USA. I've extracted the nss.npa with the extract_sg_en.exe that has linked by maefdomn (few post above mine).

After editing a few nsb files I wanted to create a new nss.npa file but the regular method to create a new one with nipa2.exe does not work. (creating a new npa file will work but Steins;Gate wouldn't start)


It has something to do with JAST USA's encryption of the files. (I think so, because the normal Nitro+ extraction tools wouldn't work with Steins;gate (JAST USA version).


I hope someone can help me with my problem.

Link to comment
Share on other sites

Hi, first, since English isn't my native language, I may speak strangely, sorry for that :unsure:
I'm trying to do the preliminary work for translation on the game "Phantom - Phantom of inferno" (The recent PC remake) but I'm facing a difficulty I can't defeat (I'm usually good with that kind of stuff though -_- ).

In the data folder, I have :

-the dx folder with the videos

-some afs archives

-a file called "sn.bin"

First I assumed the script with the game's text would be in one of the archives, but when I opened all the archives, I only found .spc and .xtx picture files (which I couldn't open, but that's not important), and some .ahx and .adx audio files (musics and sound effects). There wasn't any file that could be the script. So all of this led me to think that the key is this sn.bin file, as its size (around 1.4Mo) is close of the expected size for a script (imo).

But here's my problem : I can't open it, I can't find any solution on the internet, no matter which encodage I try to read it with, there's only gibberish characters and I'm pretty annoyed now. So if any of you already managed to open a .bin file from a nitroplus game, or if any of you has a clue about the position of the script file of this game, please tell me (I'm becoming upset here :( )

Here I put a description of the game's files :

In the main folder : 1 folder and some files about registration of the game (anti-copy protection, that's not my matter here), the main executable ph.exe, the uninstaller and the icon (and a text version of  copyright notice :D ) and the data folder.

In the data folder :

  -the dx folder, containing the game's videos

  -font48.xtx, as it's a picture format, I guess that's simply the game's font

  -0flist.dir : a text file containing the names of the 7 .afs archives and the sn.bin file

  -bg00.afs and bg01.afs contain 1934 pictures on .spc format
  -bgm.afs contains .adx format music
  -bgs.afs contains smaller versions of the 1934 pictures, on the smaller .xtx format
  -sys.afs contains some pictures and a file : adxmem.bin but as it's only 844 ko I don't think that's what I'm seeking for
  -vo.afs contains .ahx audio files, but I can't read all these files, and even if the music are played by VLC, I can't hear a sound (well, I guess that's not important anyway) these files are certainly the voices
  -se.afs contains .adx sound effects (gun sounds, car sounds, and the likes)
  -sn.bin is the mystery file I can't open, since it was listed in the 0flist.dir I'm pretty sure it's hiding something important, and since I didn't found it elsewhere, I assume that's the script file.

Here is a link for the problematic file : https://mega.co.nz/#!1ZwVWQgD!qqtG5Q7I7rZRIK41SnavJKK57204pFMwYCM6CImZAKY(If you dont like MEGA or if it doesn't work for you, I can send the file or any other file from the game by mail, just ask me)

Well I hope someone have a solution for me, because I'd really like to share this good visual novel with people.

Link to comment
Share on other sites

I tried running game after having replace th voices archives with an archive containing only the 9 last files of the original archive : the game put these 9 voices files on the 9 first lines and then refused to go any further (the game didn't crash, but th story couldn't continue), but it didn't crash. Then I tried to delete some random parts in sn.bin, either the game return to the menu when i click "start game", either it crash. I tried to edit bg00.afs by replacing the two first files with copies of the two following files : there wasn't any problem. Here's what I think about the afs archives : as long as there's the good number of files there's no problem if the content isn't the expected content, the first of the two extractors I used for these archives (afs util from shentrad) just gave me formatless files (file01, file02, etc.) only the second one (crass) gave me the files' names and formats (I had to use the first one to repack though). The game just take the content of the archives in the order they are put.
But editing the sn.bin carelessly (well as I only see some weird symbols I can't know what I'm editing) seems to cause the game to have tougher reactions.

The absence of an expected video file just stop any progression, just like the absence of voices files.

Link to comment
Share on other sites

Yeah, thanks anyway, I'll search methods to open bin files from xbox games, since the original remake was a xbox game.
But still, why these guys let all the multimedia files readable for anyone but hid the script behind an ugly encryption ? :(


EDIT : It seems that a Chinese amateur group released a patch, I'll try to contact them.

Link to comment
Share on other sites

This is the case for most VNs, it's pretty much like saying "No one can fan translate a VN, if they have no access to the scripts/texts of the VN", there isn't much to do if all you have are the images and videos and they really don't matter. But if anything, it's how the game engine builds the files and how it is able to read them.

Link to comment
Share on other sites

Ok, my quest seems harder than I thought, I didn't manage yet to contact the Chinese team, but I obtained their release : the original executable is 835 ko, their patch consist in a 389 ko replacement executable and a 38 Mo .chs file, it seems I'll have no choice but to ask them directly, (and pray to be understood, I don't understand a word of Chinese)

Link to comment
Share on other sites

Ok, I'll try to prepair a 'light version' for editing, if I reduce the game that much, you will not be able to go past the first video but if it's enough...

EDIT : Done, I have a light version (314 Mo, 187 Mo in a .zip), I'm uploading it now, the game runs correctly up to the first video (missing in the package). I'm uploading it right now. Btw I just realized I gave you the French notation Mo instead of MB up until now, sorry for that x)


EDIT 2 : Here is the link : [i deleted the link, PM me for information]

Link to comment
Share on other sites

Ok, I'll try to prepair a 'light version' for editing, if I reduce the game that much, you will not be able to go past the first video but if it's enough...


Maybe, maybe not. It depends if the game does its decryption/decompression when loading the file or if it does it only when reading it. You could do it to the first line of dialogue to be a bit safer, but we'll see.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...