Jump to content

Line Spacing Issue in A Sky Full of Stars (ADVHD/WillPlus)

Recommended Posts

Hey everyone,

I've been working with Interstellar Focus, but there's a problem, the space between lines is too large and wastes space. Combine that with the fact that English takes up more space than Japanese, then we have a problem. 

Here's an example of the text box in Interstellar Focus:


and here's how it appears in the main game:


It's my first time doing this kind of thing, so I am not quite sure what to do or where to look. 
There are also times where, no matter how much I can possibly increase the amount that can fit into the textbox, there will be some words dropped. 
I'm concerned that this might become a problem when an extra explanation is needed to bridge cultural gaps.
Is there also a way to add more "dialogue", like more textboxes?

Here are the tools I used:
GarBRO - Extracting .ws2 files from arc files, putting them back in after finishing
VNTextPatch - Converting .ws2 to json and back into .ws2 after

Link to comment
Share on other sites

I located the configuration file and changed the value from 50 to 70. I ran the vntextpatch tool and created an archive with garbro.
However, despite these steps, it seems that the line width remains unchanged when I play the visual novel. As a test, I even set the value to 1, but there was still no visible difference in the text display. Could it be that I overlooked a step?

Link to comment
Share on other sites

Thank you both for your suggestions. I edited the "ProportionalLineWidth" option, changing it to 1700. Unfortunately, it seems that this change had no effect on the line width in the visual novel.

If the line spacing is indeed hardcoded in the .exe file, it would be disappointing, as I have no experience in reading and writing code, even more so when it comes to already compiled executables that may have protections in place. 

I truly appreciate your help thus far, and I'm open to any additional suggestions or guidance on how to tackle this line width issue.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...