Jump to content

Fixes to common problems with Visual Novel Reader

Recommended Posts

how do i fix this? I can't freaking see anything :(

everything looks so tiny



I think I've seen this before...




And the solution we found.


Try updating first.


Try restoring the system default font settings:



Restart VNR for changes to take effect.


If that doesn't work:

I don't know, I've checked the register keys and values for VNR and didn't find any suspicious one to change the font.

Try reinstalling VNR.


If VNR against all odds would save it's settings through the reinstall:


Manually delete VNR, remove it's register keys/values:


start->type "regedit" run that program go to

HKEY_CURRENT_USER / Software / sakuradite.org

right click "delete"


Then install VNR again.


Hope this does it.


At least it worked for him.


I tried to manually delete the register keys and it works! Thank you very much! :D

Link to post
Share on other sites

I'm playing a VN where at the end of every sentence, a flashing triangle shows up, and that triangle is being spammed like mad everywhere in the text. I guess the only way to fix this is by enabling those "eliminate infinite repetition" options? And sentences are being repeated like 4 times, Is this a problem with VN or is it VN reader? Because I'm pretty sure when I used VN reader 3 months ago I didn't have this problem... or I could be wrong.


Also, how do I get rid of the VNreader circle at the bottom left of the screen?



Link to post
Share on other sites

Hi, can anyone here help me with this problem?  The text from previous screens won't clear and it just all stacks up into a giant jumbled mess... thanks in advance!


When I open the game and load a save file:



When I press next in the visual novel, this happens: (The text interpreter part of VNR forgets to remove the first sentence)




After about 5-6 clicks, it's covering the entire screen, which makes it super hard to read:




Also, it's worth mentioning that out of my 9 owned novels, it only does this for Daito

Link to post
Share on other sites

I've played daitoshokan with VNR, without problems, so I know it works.


For the hooks it works like this: The first person playing the VN gets to choose a text-hook and commit it to the VNR database, then that becomes the default hook for that game.


To configure the hook, read my first post in this thread.


Best wishes.

Link to post
Share on other sites

"Not that lucky? Then we have to get the /h code with ITH"


I had to use that method for Ao no Kanata no four Rhythm, because with VNreader it showed incorrect text. Now whenever I start the game, I have to go to text settings in VNreader, and enter the H-Code for the text to show up. Why doesn't the code stay saved in VNreader? Am I doing something wrong? This is just an annoyance, I guess. It also says the code was recently deleted by other users.

Link to post
Share on other sites

 Why doesn't the code stay saved in VNreader? Am I doing something wrong? 



Also, how do I get rid of the VNreader circle at the bottom left of the screen?



Have you tried updating VNR or if it's older than some months, installing a new version of it. That circle indicate that VNR is trying to get the shared data from the VNR database (like /h codes and game configurations).


I'd suspect you can't submit if you're running outdated versions of VNR (because those /h codes you try to remove actually work on the updated versions) or running not signed-in. 


I had no problems running Aokana, using the most recent version of VNR.

Link to post
Share on other sites
  • 4 weeks later...

I was hoping to see if I could get some help with an issue I'm having with visual novel reader. I'm still pretty new to vnr, in case that matters. Anyway, I've been using vnr to translate and play a few RPG maker games. The first game I loaded worked perfectly, but when I tried to add another rpg maker game, vnr automatically replaces the location of the first game in my springboard. I haven't gotten very far in the second game to be absolutely sure, but I don't think this is causing any problems with the translation. I think the problem has to do with the fact that all rpg maker games have the same process name, "Game.exe", and changing the name of the .exe file doesn't seem to change this. I had vnr automatically update since then, so I believe I'm using the latest version, but the problem remains. Is there anything I can do to get around this? And, if that's not possible, then will this cause any problems further down the line. The main reason I'm concerned is becuase each game I load seems to keep the 907 comments that came from the first game I added, and I'm not sure how the comments effect the translation in vnr.

Link to post
Share on other sites

OK, so VNR associates games with their process name, well that can be changed.



However then you have a custom process name, so other people won't get your comments probably.

Also VNR has an auto-detect running VN feature, so you don't really need to launch the game from the springboard, you can just launch it normally and let VNR detect it.

I usually do that for VNs when they needs to be launched by a crack, since they can't be launched by the springboard then.


Hopefully this helps.

Link to post
Share on other sites
  • 1 month later...


Really enjoying using VNR to play both novels and rpg maker games, the only issue I am having is trying to find a way for VNR to interact nicely with full screen games, when I launch a full screen game all I get is a flickering version of the translation window at best.

Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...

#1 probably because two sources are selected.


  • Have the latest version of VisualNovelReader
  • Click Menu -> Text Settings in the left-hand floating window.
  • You hopefully see boxes with text for "Text threads" if not, experiment with text encoding
  • Get some text and tick the box with the dialogue with "dialog"
  • CLICK [sAVE]
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...