Jump to content
exbonkura

Probably some Window 10 problem regarding Japanese text and even startup of VNs

Recommended Posts

Hey there.

So, I've been following VNs and the community for almost 6 years now. During my initial years as a VN reader, I had a laptop with windows 7 in it, and I never ever had any problem regarding Japanese VNs. Just with a quick search on google I realised I need to set my locale to Japanese, and I did. But you know, some visual novels out there need an extra setting: Date and time format I think it's called? Well, when I came across those VNs, I again did a quick google search and found the solution to my problem.

But it seems that no one has discussed my current problem online (as far as I have searched), so I thought about doing it myself.

The laptop I talked about earlier with windows 7 broke a year and a half ago, so I got a brand new one with windows 10 in it. As I said in the title, my problem most likely has something to do with this new windows 10. The problem is that changing the format doesn't seem to have the effect that it should. Changing the format changes nothing. Some VNs are not running at all because of it, and the Japanese in the error boxes or the dialogue boxes or whatever they are called doesn't display: it's gibberish. Just to make sure, I changed not only the system locale and the format to Japanese, but all the "things" about my PC that I could: windows display language, date, clock, region, everything I could find. Of course, I have no knowledge of CS, so it was just a wild, random action on my part. It did no good.

This one VN that's having problem in my pc runs perfectly fine in my brother's 8 years old laptop (I just checked) with windows 7 in it. All I had to do was change the locale and the format to Japanese.

I am at a loss on what to do, so help me if you can; I'd be extremely grateful. Thanks in advance. And thanks for reading my awkwardly written post :).

Share this post


Link to post
Share on other sites

I'll just throw everything at the wall and see what sticks.

1. Did you carry over the files from your old computer to your new one? If you simply copy&pasted them over or used Cloud storage or something, you probably have to actually reinstall the VNs. (I actually just migrated over to Windows 10 from Windows 7 on an old computer yesterday, and I found that some games required a reinstallation.) If you want to be extra safe, you may opt to simply re-download the games anew.

2. Is this the "gibberish" you're talking about?:

zrYTMzI.png

If so, I just came across the same problem. I know you said you changed the "windows display language, date, clock, region, everything I could find," but I found that changing the region very specifically fixed the issue, so I just want to make sure you did that properly. Your region in Windows 10 should look exactly like this:

OB73z6N.png

3. When you say you changed your "Windows display language," you mean you added the Japanese language pack, correct? Your "Preferred languages" screen should look like this:

unknown.png

4. This may be obvious, but did you restart your computer after changing your system locale?

Share this post


Link to post
Share on other sites
Quote

2. Is this the "gibberish" you're talking about?:

Actually, yes and no. The "gibberish" is the same, but the "placement" is wrong. The actual text of the novel and the title on the upper-left corner of the game window do show fine FOR THE VNs THAT DO RUN. The problem is, let's say, you click on the close window button on the upper-right corner. In this case, you would see a box pop up asking you if you really want to quit, right? So the text in that box would show like that "gibbberish". This and sometimes it happens that the text in the game setup windows/boxes would be unreadable (like, all of it). And you know how sometimes the setup finds an error during installation and tells you about it? In all those error boxes and message boxes, the text is like that "gibberish". Please note again that here I'm talking about a few novels which did run on my new pc. Some aren't running at all, presumably because of the same underlying problem. You see, the small issues which I've highlighted above shouldn't matter all that much in the long run; they are irritating yes but as long as I can read the main text of the novel, I'm cool. But the real issue seems much deeper than that, and it's affecting a lot of things. 

Quote

 Did you carry over the files from your old computer to your new one? 

No, I did not. Everything was lost on my previous hard drive.

Quote

I found that changing the region very specifically fixed the issue, so I just want to make sure you did that properly.

Just to make sure, I'll do it again. But like I said, I've done it many times already. Like I said, my brother's old windows 7 laptop did not have this issue to begin with. All I did there was change the locale and the date format.

Quote

 you mean you added the Japanese language pack, correct?

Yes, I did add the language pack. It was pretty much the first thing I did when I got the new laptop. I should add that I have the supplementary Japanese fonts installed as well. I read somewhere that it solved some problem regarding fonts for some person. It didn't for me, though.

Quote

did you restart your computer after changing your system locale?

Yes, I did.

Share this post


Link to post
Share on other sites

Did you install Japanese Supplemental Fonts (Settings > Apps & Features > Optional Features)?  Windows 10 doesn't come with these already installed and many visual novels won't work without them also make sure the Non-Unicode Language is set to Japanese.

I don't have issues with visual novels on Windows 10 except the older ones that use DirectDraw since Windows 8 and 10 don't support it.  I've never had to use compatibility mode on any visual novel and you should never have to use it.

Edited by Shaun

Share this post


Link to post
Share on other sites
Quote

Maybe giving the VN title would help.

The reason why I haven't dropped any VN title is because I don't want to give the impression that my problem is specific to some particular VN. 

But I'll give an example: recently, I installed the VN "Hyakki Ryouran no Yakata". Long story short, I have two laptops, ok? I tried installing the said VN in both of these laptops to check if my problem is specific to my windows 10 laptop or if it occurs in the windows 7 laptop as well.

In the windows 7 laptop when you finally run the game and click "start", it gives this error: 

Quote

scr_load : ファイルのオープンに失敗しました。
file : "script\sys_main.bin"

This is resolved if you simply change your date/time settings to Japanese (besides the locale, of course).

 

 

Now, in my windows 10 laptop, the game installs just fine but when you run the game and click start, it gives this error:
 

Quote

load_file : �t�@�C���̃I�[�v���Ɏ��s���܂����B
file : "bg\��.lsf"

It's basically unreadable but anyone would say that they are different errors, right? And unlike with windows 7, it isn't resolved even when I change my date/time settings to Japanese. I should add (again) that yes, my system locale is in Japanese.

First of all, it's obvious that the problem lies somewhere other than the date/time or region settings. What I don't understand is why the hell does the text not show correctly even with the locale set to Japanese along with the date/time settings??? It seems to have never happened before with anyone......

Share this post


Link to post
Share on other sites
Quote

Did you install Japanese Supplemental Fonts (Settings > Apps & Features > Optional Features)?  Windows 10 doesn't come with these already installed and many visual novels won't work without them also make sure the Non-Unicode Language is set to Japanese.

Yes, like I said in my second post on this thread, I have installed Japanese Supplemental Fonts. 

Quote
 Quote

 you mean you added the Japanese language pack, correct?

Yes, I did add the language pack. It was pretty much the first thing I did when I got the new laptop. I should add that I have the supplementary Japanese fonts installed as well. I read somewhere that it solved some problem regarding fonts for some person. It didn't for me, though.

I suspect my problem has to do with something else entirely...

Share this post


Link to post
Share on other sites

By the way, have you tried locale emulator? Personally I don't even bother changing my system locale and have no problem with it.

So far, the only problem I had was that one VN that couldn't save unless I use Windows XP Service pack 2 compatibility, but don't remember what it was.

Share this post


Link to post
Share on other sites
18 minutes ago, exbonkura said:

Alright, this is weird. I just went and tried to change my locale back from Japanese to something else but it's not working. I mean, nothing's happening...... I open the language menu and click English (United States) and click "ok" but then it just goes back to showing "Japanese (Japan)" as the locale.

It has been over a year since I changed my locale for the first time from English to Japanese, but from what I remember this didn't happen back then. When I selected Japanese and clicked "ok" it immediately asked me to restart my pc. But it's not happening now...... I don't even know what's going on anymore...

Yeah it should ask for restart immediately.

If you can't get it to change with a restart now (just change it to English and click OK even if it doesn't ask for restart and restart yourself) then there are 2 things you could still try:

1. System restore / system file checker tool (google it)

 

2. Creating xml file with notepad

<gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
<gs:UserList>
<gs:User UserID="Current" CopySettingsToDefaultUserAcct="true" CopySettingsToSystemAcct="true"/>
</gs:UserList>
<!-- system locale --><gs:SystemLocale Name="en-US" />
</gs:GlobalizationServices>

system-locale-settings.png

and running in command prompt (admin mode) where D:\locale.xml is whatever the file path to your xml file is

control.exe intl.cpl,, /f:"D:\locale.xml"

and then restarting your PC.

Share this post


Link to post
Share on other sites

Thank you so much Yuuko. Your suggestion actually worked. Changing my locale back to English and then again back to Japanese seems to have solved the issue. The text is showing correctly now...

 

As for why locale wasn't changing, I didn't read your second message above but randomly unchecked this option (which is below the "language menu" in the change locale option). It was just a random action on my part but it seems to have done the trick.

Quote

Beta: Use Unicode UTF-8 for worldwide language support.

 

Once again, thanks to you, Yuuko. And of course, everyone else above who gave their suggestions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×