Jump to content
kudaratan

Encrypted Kirikiri game won't read patch?

Recommended Posts

Hello, I'm trying to make a patch of a game called Hatsukare Ecchi, but for some reason, I can't seem to make a patch it will read. When I use any programme other than KrkrExtract it ignores the file, but when I do use it, I get this error:

ECpikMf.png

What should I do? Any help is appreciated, thank you!

(Sorry if the answer is somewhere on here, I tried looking it up and couldn't find anything. ^^;;)

Edited by kudaratan

Share this post


Link to post
Share on other sites

Check initialize.tjs to make sure the patch file is in the correct location, and if the game is using an encryption plugin, make sure that the patch file is encrypted correctly, or decrypt all of the files and remove the encryption plugin.

Share this post


Link to post
Share on other sites

Thank you for replying! The patch is named correctly, but I'm unsure how to encrypt it correctly. KrkrExtract gives a "can't open" error when I make the patch, and the game tries to load it, but gives the error above and then the game closes. :( Are there any other tools for building an encrypted patch.xp3?

Share this post


Link to post
Share on other sites
21 hours ago, kudaratan said:

Thank you for replying! The patch is named correctly, but I'm unsure how to encrypt it correctly. KrkrExtract gives a "can't open" error when I make the patch, and the game tries to load it, but gives the error above and then the game closes. :( Are there any other tools for building an encrypted patch.xp3?

Try GARbro.

Share this post


Link to post
Share on other sites
2 hours ago, uyjulian said:

Try GARbro.

still not seeming to work :( I either get the error above, or the game plays and just doesn't show any changed text from the patch at all.

Edited by kudaratan

Share this post


Link to post
Share on other sites
2 hours ago, kudaratan said:

still not seeming to work :( I either get the error above, or the game plays and just doesn't show any changed text from the patch at all.

Did you select the correct encryption when prompted in GARbro? 『読み込みエラ一です。ファイルが破損している可能性や、デバ'イスからの読 み込みに失敗した可能性があります』 probably means that you did not encrypt the file correctly, so the hash check failed. Try decrypting all the data files, repacking with NO encryption, then deleting the encryption plugin (usually extension ends in .tpm)

Edited by uyjulian

Share this post


Link to post
Share on other sites
10 hours ago, uyjulian said:

Did you select the correct encryption when prompted in GARbro? 『読み込みエラ一です。ファイルが破損している可能性や、デバ'イスからの読 み込みに失敗した可能性があります』 probably means that you did not encrypt the file correctly, so the hash check failed. Try decrypting all the data files, repacking with NO encryption, then deleting the encryption plugin (usually extension ends in .tpm)

I could be blind, but I'm not seeing a .tpm file... :(
I went ahead and downloaded the russian version of the game, and patching it seems to work fine, so I might work based off that version instead.

Thank you for all your help, though! I wish I could make a patch for the normal version still. :(

Share this post


Link to post
Share on other sites

the encryption plugin isn't allways the .tpm
a common name is 'krkrsteam.dll' too.
and the plugin can appears inside or outside of the plugins directory.
If you don't found send screenshot of the all files in the plugin directory and we can say.
Some very rare cases are 'modified builds' of the engine that will need you replace the main engine exe too.

Edited by marcus-beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×