Jump to content

Lowすぺっく!? (EN TL) - G00packMax and multi-layer g00 files (Problem)


Recommended Posts

Looks like the way I was doing it was wrong from the start. I found a link to a good tutorial in this post, but now there is a new problem, I can't find a way to replicate the "No Data" layers in g00 files:


I thought using transparent dummy images would work, although the layers are all in the right sorting order, looks like without "No Data" layers the game automatically adds empty space to the top and to the left, pushing all textures to the right. Are there any commands in G00PackMax for changing a layer's attribute to No Data?

EDIT: After some fiddling with an hex editor, it turned out that changing the attributes was easier than expected. First it's to note that the input PSD file was just a normal PNG created from merging the unpacked texture files with ImageMagick and exporting the PNG to PSD with GIMP.

The sorting order doesn't matter as long as the images are keeping the numerical name, it can be a 1x100 or 2x50 collage, as long as it's specified in G00packMax's command line (the txt file), it makes no difference.

The g00 output file and the original both have most of the informations about layers stored right in the header, the very first bytes. The new g00 will look a bit different but it's easy to understand where last byte of the header ends in both files. Overwriting the new header with the one from the original g00 file will fix the attributes making it exactly like the original.

Yet... the problem ingame doesn't change, there are other bytes that need editing somewhere else in the file, the more likely way to fix this is to just find the transparent images' bytes and replace them with 00s but I haven't tried yet, I'm still trying to figure out where the image data actually starts. Since the output file has a very different structure compared to the original g00 file, a normal comparison of the bytes won't be enough.

Edited by onii
some progress
Link to comment
Share on other sites

  • 2 years later...

Oh crap, these two years went by so fast. Today I found the bookmark of this page, might as well bump one last time before my time expires.

Anyone else tried to translate Lowすぺっく yet? I don't have the project files anymore, still, I'd gladly support any kind of translation projects or ideas related to this VN.

I'll dump some pm's with some information I was exchanging with another translator.

On 3/2/2019 at 1:55 PM, onii said:

Hi! I started translating this VN v18875 a few days ago but, since I'm not sure I can fix all the issues, I haven't announced anything officially, there're a bit of troubles with these g00 files that I wanted to fix beforehand. Talking about that, in this image is a comparison of the 2 files, the one on the back is the new repacked file I made, while the window on the front shows the original g00:


The layer number 024 and many other layers were supposed to be "No Data" layers like in the original, I used dummy images because I didn't find a command for G00PackMax to create empty layers but it didn't work, I mean the game loads fine and the textures are loaded too but they're in the wrong position:


I think the transparent layers are the cause.


On 3/2/2019 at 2:10 PM, onii said:

No problem, thanks. The game version I'm using is the one downloadable for free from DL Site, if you need here is the download page (1.29GB trial version): https://www.dlsite.com/pro/work/=/product_id/VJ010507.html

This here is the test g00 file I made, only one texture is translated for testing and it's the "tutorial" button, like in the screenshot.

File's location: ...\Lowすぺっく_体験版_ver1\StartData\GameData\g00


On 3/3/2019 at 7:03 AM, onii said:

Separate and merged pngs here: https://my.mixtape.moe/xqlkzj.zip

I'm merging them using ImageMagick's montage function:

montage *.png -tile 2x47 -geometry 238x118 -background none output.png

All the blank images are placeholders I made and they're supposed to be the "No Data" layers, there weren't any blank images when I unpacked the g00 file, but they had numeric file names and files were missing when it was supposed to be a no data layer.

The layer order is probably needed I guess, so I tried to keep the images in the same sorting order as the layers in the original g00, though I haven't edited enough pngs to confirm whether removing the blanks makes any difference yet (it looks the same from the main menu, still glitched).

The original g00 is on 2 columns but looks like the result is the same with 1x93:


If you want to compare with G00libMax, this is the original unedited g00 file: https://my.mixtape.moe/ejbxub.zip

EDIT: after some testing, I'm thinking the issue is with the g00 format that G00PackMax uses as output. I saw that vaconv-cpp supports different output formats but it still can't create multi-layer g00 files (or at least I didn't find any parameter like that in --help) so I sent a message to the user who made the cpp version, maybe he knows what's wrong with these textures.


Edited by onii
Link to comment
Share on other sites

  • onii changed the title to Lowすぺっく!? (EN TL) - G00packMax and multi-layer g00 files (Problem)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...