Jump to content


Recommended Posts

Hey everyone. I managed to get my hands on a PS4 copy of NEW GAME: THE CHALLENGE STAGE and decrypt the disc. As the game is by 5pb, the files are a familiar "_info.psb.m" and "_body.bin" format, but I cannot seem to extract them, much less repack them. As this game was a JP-only release, I'm very keen to get started on translating it. It's worth mentioning that this game was released closely to the Re:ZERO visual novel, and while I've only got the PSVita version of that, I can venture a guess that it has the same file formats (PSV + PS4 are both little-endian as well).

If anyone wants to take a stab, I've uploaded the decrypted (ready for IDA) ELF file, as well as a couple of small sample files: http://slynch.xyz/Downloads/newgame_challengestage_ps4.zip

Share this post

Link to post
Share on other sites


key is 1232ab23478cd

keylength 0x83 

https://github.com/number201724/psbfile worked on the psb file I tried (text.psb.m) but it only has UI strings

https://a.uguu.se/Yrc25VoNmEpi_h.7z even though there is source for exm2lib it is missing too much to easily recompile it so I replaced index 1's key


   "DIALOG_AUTOSAVE_NOSPACE" : "%C本体ストレージの空き容量が不足しています。\n$Sを保存するには\n空き容量があと%dKB以上必要です。",
   "DIALOG_AUTOSAVE_WARNING1" : "%C本ゲームはオートセーブ機能に対応しています。",
   "DIALOG_AUTOSAVE_WARNING2" : "%Cオートセーブ中にはメモリースティック™アクセスランプが\n点滅しますので、記録メディアを抜いたり、\n本体の電源を切ったりしないでください。",
   "DIALOG_CHECK_HDD_SPACE" : "%C本体ストレージの空き容量を確認しています。",
   "DIALOG_CHECK_TROPHY" : "%Cトロフィーをチェックしています。",
   "DIALOG_EJECT_STORAGE" : "%Cストレージが取り外されました。",
   "DIALOG_INSTALLED_ENABLED" : "%Cデータインストールの設定を有効にしました。",
   "DIALOG_INSTALLED_ERROR" : "%Cゲームデータの\n読み込みに失敗しました。\n代わりにUMD®から読み込みます。",
   "DIALOG_INSTALLED_ERROR_BROKEN" : "%Cゲームデータが\n壊れていました。\n代わりにUMD®から読み込みます。",
   "DIALOG_INSTALLED_ONCE_DISABLED" : "%Cデータインストールの設定を一旦、無効にしました。",
   "DIALOG_INSTALL_DESCRIPTION" : "%Cインストールを開始します。\n完了までに数分間かかりますので\n途中で電源が切れないように気をつけて下さい。",
   "DIALOG_INSTALL_NOSPACE" : "%C不要なセーブデータを削除して\nインストールに必要なだけの空き容量を確保して下さい。",
   "DIALOG_INSTALL_RETRY" : "%Cインストールが途中で中断されました。\n最初から再びインストールを試みます。",
   "DIALOG_INSTALL_TROPHY" : "%Cトロフィーをインストールしています。",
   "DIALOG_LOADING" : "%C$Sを読み込んでいます。",
   "DIALOG_LOAD_FAILED" : "%C$Sを読み込めませんでした。\n$R",
   "DIALOG_LOAD_FAILED_STARTUP" : "%C$Sを読み込めませんでした。\n保存時に、自動作成されます。",
   "DIALOG_NO_HDD_SPACE" : "%%C本体ストレージの空き容量が足りません。\nあと%dMB 以上必要です。\nゲームを終了して、必要な空き容量を確保してください。",
   "DIALOG_PLAYER_SIGNOUT" : "%Cプレイヤーがサインアウトしました。",
   "DIALOG_READING" : "%C$Sを読み込んでいます。",
   "DIALOG_READ_FAILED" : "%C$Sを読み込めませんでした。\n$R",
   "DIALOG_SAVE_DONE" : "%C$Sを保存しました。",
   "DIALOG_SAVE_FAILED" : "%C$Sの保存に失敗しました。",
   "DIALOG_SAVE_FAILED_RETRY" : "%C$Sの保存に失敗しました。\n作成しますか?",
   "DIALOG_SAVING" : "%C$Sを保存中です。\n電源を切ったり、アプリケーションを終了\nしたりしないでください。",
   "DIALOG_TUS_DOWNLOAD" : "%Cダウンロードしています。",
   "DIALOG_TUS_DOWNLOAD_FAILED" : "%C通信エラー発生によりタイトルユーザーストレージからの\nダウンロードを中止しました。",
   "DIALOG_TUS_DOWNLOAD_FAILED_ERRORCODE" : "%C通信エラー発生によりタイトルユーザーストレージからの\nダウンロードを中止しました。\n(ERROR $E)",
   "DIALOG_TUS_DOWNLOAD_FAILED_NODATA" : "%Cタイトルユーザーストレージにデータがありません。",
   "DIALOG_TUS_DOWNLOAD_FAILED_SIGNOUT" : "%Cサインアウトによりタイトルユーザーストレージからの\nダウンロードを中止しました。",
   "DIALOG_TUS_DOWNLOAD_INVALID_SAVEDATA_OWNER" : "%Cタイトルユーザーストレージのアクセス制限の為、\nダウンロードを中止しました。",
   "DIALOG_TUS_DOWNLOAD_SUCCESS" : "%Cダウンロードが完了しました。",
   "DIALOG_TUS_LOGIN_FAIL" : "%Cオンラインでないため処理を中止しました。",
   "DIALOG_TUS_LOGIN_FAIL_AGE" : "%CSony Entertainment Network アカウントの年齢制限により、\nこのコンテンツはご利用になれません。",
   "DIALOG_TUS_UPLOAD" : "%Cアップロードしています。",
   "DIALOG_TUS_UPLOAD_FAILED" : "%C通信エラー発生によりタイトルユーザーストレージへの\nアップロードを中止しました。",
   "DIALOG_TUS_UPLOAD_FAILED_ERRORCODE" : "%C通信エラー発生によりタイトルユーザーストレージへの\nアップロードを中止しました。\n(ERROR $E)",
   "DIALOG_TUS_UPLOAD_FAILED_SIGNOUT" : "%Cサインアウトによりタイトルユーザーストレージへの\nアップロードを中止しました。",
   "DIALOG_TUS_UPLOAD_INVALID_SAVEDATA_OWNER" : "%Cタイトルユーザーストレージのアクセス制限の為、\nアップロードを中止しました。",
   "DIALOG_TUS_UPLOAD_SUCCESS" : "%Cアップロードが完了しました。",
   "ERROR_ACCESS" : "%C記録メディアにアクセスできません。\n",
   "ERROR_BROKEN" : "%Cデータが壊れています。\n",
   "ERROR_EJECT" : "%C記録メディアが抜かれました。\n",
   "ERROR_NODATA" : "%Cデータがありません。\n",
   "ERROR_NOMEDIA" : "%C記録メディアが入っていません。\n",
   "ERROR_PROTECTED " : "%C記録メディアがロックされています。\n",
   "YESNO_ALOAD" : "%Cオートセーブデータをロードしますか?\n(保存していないデータは失われます)",
   "YESNO_CREATE_DATA" : "%C$Sを読み込めませんでした。\n$R作成してもよろしいですか?",
   "YESNO_DOWNLOAD_TUS" : "%Cオンラインに接続してタイトルユーザーストレージから\nデータをダウンロードしますか?\n現在のセーブデータは上書きされます。",
   "YESNO_INIT" : "%C設定を初期化しますか?",
   "YESNO_INSTALL_OVERWRITE" : "%Cすでにインストール済みです。\nインストール済みの古いゲームデータを削除して上書きしますか?",
   "YESNO_JUMP" : "%Cこの地点から再開しますか?\n(保存していないデータは失われます)",
   "YESNO_LISTDELETE_NOSPACE" : "%C本体ストレージ上のデータを削除して\n保存に必要な空き容量を確保しますか?",
   "YESNO_LOAD" : "%C$Sを読み込みますか?",
   "YESNO_LOAD_RETRY" : "%C$Sを読み込めませんでした。\n$R再び読み込みを試みますか?",
   "YESNO_NEXT" : "%C次の選択肢まで進みますか?",
   "YESNO_OVERWRITE_DATA" : "%C$Sを読み込めませんでした。\n$R上書き作成してもよろしいですか?",
   "YESNO_PREV" : "%C前の選択肢まで戻りますか?\n(保存していないデータは失われます)",
   "YESNO_QLOAD" : "%Cクイックロードしますか?\n(保存していないデータは失われます)",
   "YESNO_QSAVE" : "%Cクイックセーブしますか?",
   "YESNO_QUIT" : "%Cシーンギャラリーに戻ります。\nよろしいですか?",
   "YESNO_READ_RETRY" : "%C$Sを読み込めませんでした。\n$R再び読み込みを試みますか?",
   "YESNO_SAVE" : "%C$Sを保存しますか?",
   "YESNO_SAVEBROKENRETRY" : "%Cデータが破損しているためセーブに失敗しました。\n一旦削除してから再びセーブを実行しますか?",
   "YESNO_SAVE_OVER" : "%C$Sを上書き保存しますか?",
   "YESNO_SAVE_RETRY" : "%C$Sを保存出来ませんでした。\n$R再び保存を試みますか?",
   "YESNO_SCENARIO_JUMP" : "%Cシナリオ再生しますか?",
   "YESNO_TITLE" : "%Cタイトル画面に戻ります。\nよろしいですか?\n(進行状況をセーブしていない場合は\n続きからプレイができません)",
   "YESNO_TITLE_NOSAVE" : "%Cタイトル画面に戻ります。\nよろしいですか?",
   "YESNO_UPLOAD_TUS" : "%Cオンラインに接続してタイトルユーザーストレージへ\nデータをアップロードしますか?\nタイトルユーザーストレージのデータは上書きされます。"



Share this post

Link to post
Share on other sites

Awesome, you're a star. I'll take a look at it after work and see what I can do. One thing I'm not clear on; you say we can't rebuild or just that with modification to one of the applications we can? 

EDIT: Just understood what you meant by replacing index 1's key. I'll see about rebuilding from exm2lib's source code. If anyone else wants to take a stab feel free.

EDIT2: Can't compile exm2lib (latest) since I can't find the "as-ps3" and "as-zlib.h" headers. Any idea where to find them?

EDIT3: Yeah you weren't joking, author of exm2lib has made some crucial parts private and only the main CPP public. 

Edited by Slynch

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.