Jump to content

Rewrite Launching Problems

Recommended Posts

Are you running your computer with Non-Unicode Japanese? : Yes

Game: Rewrite

Description of Problem: When I launch the SiglusEngine nothing happens. At all. And no matter what I try I can't even get an error message.

Your Operating System: 64 bit Windows 7

What did you already try? (Uninstall/Reinstall, Redownload, Run as admin, etc):

Redownloading from another source

Running the .bat file included (runs fine)

Downloading the other two siglusengine files mentioned in the rewrite readme

Searching for the Gaijin Hack and downloading it manually

Installing CCCP codecs (yeah, I didn't expect that one to work)

Did you download your game from Fuwanovel?: Yes, also tried a non-Fuwanovel version

Worth mentioning I'm always running as admin. Usually a good google search turns up VN fixes, but while this one turned up a whole lot of similar problems, I didn't really see any the same.

Link to post
Share on other sites

Are you running Make_Rewrite_Work2.bat to start the game?

Any other file will not start the game.

I wasn't doing that, but when I switched to it nothing happened.

hey for the non-fuwa version, you can try the no-dvd crack down there:


i remember Rewrite is very annoying, u have to have two cracks. one for the DVD, and one for the gaijin block

That doesn't seem to help either.

Can you verify in your registery if the keys are here ?

If so try and move reg.ini from the rewrite folder somewhere else then run the game.

I can verify that the keys are in the registry. Tried that and it didn't do anything either.

However, by some luck, and some experimentation I found that running the rewrite and rewrite32 registry entries progressed me to an error message when launching the game.

Error message

Link to post
Share on other sites

That's because if you run the registry files separately it will insert wrong data into the registry. You need to use the bat file to have correct registry keys.

Bah, I was hoping I'd at least got some clue.

Nothing different happens when I move the reg.ini file out and then try and launch, so I'd guess my problem isn't in the registry. I just have no idea where it is.

Link to post
Share on other sites

Right, after retrawling through old threads I think I've got a vague idea of what's happening.

When I run the make_rewrite_work.bat file it creates the rewrite.modif file, and then deletes it before it's done. I edited the .bat file and removed the "if exist rewrite_modif.reg del rewrite_modif.reg" line from it, and now the rewrite.modif file remains. Unfortunately that doesn't open Rewrite either and the CMD window closes itself shortly after.

Now from this thread: I've figured that I probably have to remove the Wow6432Node part from the rewrite.modif file, I can edit and do that easily, but how do I get it to remain that way when I run the .bat file again?

Link to post
Share on other sites

You said you are running 64-bit Windows so Wow6432Node is needed. It should be only removed for 32-bit windows.

Rewrite_modif should have all the correct registry entries in it so check that the exe_dir and dat_dir match the path where rewrite is located on your pc.

Link to post
Share on other sites

sorry too high level, i can't help at all...


but the error message says:

"couldn't find the executable file. registry is broken.

if you reinstall the game it might fix it"

Link to post
Share on other sites

Thanks for the error message translation, I had wondered what I'd done.

Yeah I got a bit confused between the 32 bit and 64 bit fixes it seems.

Windows Registry Editor Version 5.00



"setup_dir"="C:\\Program Files (x86)"




All appears to be in the right place to me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...