Jump to content

Changing system location? Why?


Recommended Posts

So I have been playing Majikoi and after completing several routes I decided to try Majikoi S. Long story short, in the process of downloading Majikoi S I has to change the system location to Japan because the words were a bunch of symbols and the game wouldn't open up showing me a message that I couldn't read. I changed it to Japan and the game started working... All is ok right? Wrong. Well Majikoi S now works but whenever I open the original Majikoi all my save files are gone unless I change the system back to United States (what I originally had it as) in which case all my files are back but I can no longer play Majikoi S without the changing system location to Japan.

I feel like ^this was a bit too confusing so I will summarize my question without the description as well. How can I have access to both Majikoi and Majikoi S without having to switch system locations.

Link to post
Share on other sites

So what is happening is most likely that when you change your region, the path for your save files changes. The reason for this is that Japan uses ¥ these in system paths, so /users/bla bla will be ¥users. What that means is that your save files suddenly appear in a different folder, and the game can't find them anymore. What you can do is copy all your save files into a backup folder, then delete your save folder. Now start up majikoi with Japanese locale, and then go into the new save folder that it makes automatically, then put the old saves back in there. 

Link to post
Share on other sites

What you change isn't your location but your locale, aka your non-unicode character settings.

If it's not set to Japanese, windows doesn't interpret file names with Japanese characters correctly (shown above by CryingWestern) which can (and often does) cause issues with reading and writing game files.

If you had your locale set to English when you created the save files, that means the save files folder probably has a completely jumbled up mess of characters as a name, hence why when you now change to Japanese it can not read that folder, because it's looking for specific Japanese characters.

A fix would probably be to rename the messed up saves folder to the proper Japanese name.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...