Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
BLVCK

(LINUX) Kamidori Alchemy Meister Help (Always Crashing)

Recommended Posts

I have been trying to play this game, but all it does is crash when I click on "New Game" It shows a menu full of random characters and boxes http://prnt.sc/aj4h6h

Everytime I try to change my locale it shows this i've been trying to do everything to add "ja_JP.UTF-8"and "ja_JP.UTF-8 UTF-8" <- Which was recommend from the SUPPORTED file. 

http://prnt.sc/aj4b69

 

Can someone please help me, I have been looking everywhere in Google on how to this and still does not work. I really want to play this game, and I know its possible to be played in linux, its just maybe my stuff is not configured properly. 

Also I have tried putting this "LC_ALL=ja_JP.UTF-8 LANG=ja_JP.UTF-8 wine age.exe" in Terminal to try to open the game but it shows this http://prnt.sc/aj4dfi
 

Would appreciate some help, I have been looking around this forum too for help, but I found nothing that works, and I hope someone can hopefully solve my problem so I can play the game. Thanks

Share this post


Link to post
Share on other sites

^What he said, or possibly move the game to that default location

Also, make sure you've installed the correct language packs, though presumably i don't need to say that

 

The amount of people using linux is pretty small, and so is the amount of people playing visual novels. The overlap is tiny. in other words, visual novel support sometimes just runs out, so if you're intending to play a lot of them, you better make sure you have a windows boot ready for when a game just will not work through wine anymore. Just a word of advice

Share this post


Link to post
Share on other sites

I use linux exclusively and play the bulk of my VNs still under wine or a windows installation on kvm when everything fails.

 

Make sure you actually have the Japanese locale installed. How you do that is dependent on what distribution of linux you use.

Share this post


Link to post
Share on other sites
1 hour ago, ittaku said:

I use linux exclusively and play the bulk of my VNs still under wine or a windows installation on kvm when everything fails.

 

Make sure you actually have the Japanese locale installed. How you do that is dependent on what distribution of linux you use.

How did you install japanese locale, cuz if you see how I did it, its one of the only ways to do it and its not working. I've looked everywhere on how to do it and it all shows the same thing but for me it doesnt work. When I do locale-gen ja_JP.UTF-8 it generates but nothing else works. I can play other games like Sengoku Rance, but for some reason I cant play this game, and watching walkthroughs of the game, makes me wants to play it seems the way the game is made is interesting.

Share this post


Link to post
Share on other sites
2 hours ago, Kelebek1 said:

From that last screenshot, why not list the full filepath, since it's defaulting to system32 where the game obviously isn't?

What do you mean list the full filepath?

Share this post


Link to post
Share on other sites

It does run on wine at least.

As the others have mentioned, your command prompt was not in the correct folder to start the game. Your screenshot shows that you're in your home folder. Think about where you installed the game at... you need to "cd" into that folder first. (In my screenshot, I installed it in wine's Program Files and renamed the game dir to "kamidori" afterwards.)

Next, using LC_ALL=ja_JP.utf-8 should be sufficient for the locale settings. That worked alright for me.

However, you need to have at least 1 Japanese font that wine can use -- or else the game will crash when it's about to show text. My preferred method is to copy "msgothic.ttc" from a Windows installation and put it in wine's font folder (that would be in ~/.wine/drive_c/windows/Fonts).

Share this post


Link to post
Share on other sites
18 minutes ago, binaryfail said:

It does run on wine at least.

As the others have mentioned, your command prompt was not in the correct folder to start the game. Your screenshot shows that you're in your home folder. Think about where you installed the game at... you need to "cd" into that folder first. (In my screenshot, I installed it in wine's Program Files and renamed the game dir to "kamidori" afterwards.)

Next, using LC_ALL=ja_JP.utf-8 should be sufficient for the locale settings. That worked alright for me.

However, you need to have at least 1 Japanese font that wine can use -- or else the game will crash when it's about to show text. My preferred method is to copy "msgothic.ttc" from a Windows installation and put it in wine's font folder (that would be in ~/.wine/drive_c/windows/Fonts).

Can I didn't install the game through this computer, I was at my friend's house and got the folder and placed it into my usb and placed it in my desktop. Can you help me on how to place it in the right spot and have the right locale, and also have the right fonts. ?

Share this post


Link to post
Share on other sites

Getting a Japanese font:
Obtaining a copy of msgothic shouldn't be too difficult. If you have a Windows machine (Vista through Win8, or WinXP with Asian language support will have it), get it out from the "C:\Windows\Fonts" folder. If you can't find one, go here and click View Raw.

Once you have the file, move it to your home folder (because I'm assuming your terminal is opened there by default). The command here will copy it to wine's font folder. It is case-sensitive.

 

cp ~/msgothic.ttc ~/.wine/drive_c/windows/Fonts
 

Start the game by command line:
If you got the game dir from another system, that is okay. You placed the game folder on your desktop, so I'll guess from your screenshot. Doing a "cd" to that folder should look like this. You will need the quote marks in the command.

cd "Desktop/Kamidori Alchemy Meister"

From there, use the appropriate command line to run wine. I'll use the same one I showed in my screenshot.

LC_ALL=ja_JP.utf-8 wine age
 

See if that works.

Share this post


Link to post
Share on other sites

I have ran the game through terminal, it loaded up, but once I clicked on "New Game" it crashed. And showed me this message "http://prnt.sc/aj7h7w"

When I downloaded the font I placed it in my "Home" folder in my desktop and ran the command 

cp ~/msgothic.ttc ~/.wine/drive_c/windows/Fonts 

This happened. "http://prnt.sc/aj7l29" Nothing really happened. I did everything you told me, but didn't seem to work, the only thing I succeeded at doing was opening the game through terminal, and btw thanks for that, but now I wonder if there is a way I can open the game without it crashing so I can play it.

52 minutes ago, binaryfail said:

Getting a Japanese font:
Obtaining a copy of msgothic shouldn't be too difficult. If you have a Windows machine (Vista through Win8, or WinXP with Asian language support will have it), get it out from the "C:\Windows\Fonts" folder. If you can't find one, go here and click View Raw.

Once you have the file, move it to your home folder (because I'm assuming your terminal is opened there by default). The command here will copy it to wine's font folder. It is case-sensitive.

 


cp ~/msgothic.ttc ~/.wine/drive_c/windows/Fonts


 

Start the game by command line:
If you got the game dir from another system, that is okay. You placed the game folder on your desktop, so I'll guess from your screenshot. Doing a "cd" to that folder should look like this. You will need the quote marks in the command.


cd "Desktop/Kamidori Alchemy Meister"

From there, use the appropriate command line to run wine. I'll use the same one I showed in my screenshot.


LC_ALL=ja_JP.utf-8 wine age


 

See if that works.

I have ran the game through terminal, it loaded up, but once I clicked on "New Game" it crashed. And showed me this message "http://prnt.sc/aj7h7w"

When I downloaded the font I placed it in my "Home" folder in my desktop and ran the command 

cp ~/msgothic.ttc ~/.wine/drive_c/windows/Fonts 

This happened. "http://prnt.sc/aj7l29" Nothing really happened. I did everything you told me, but didn't seem to work, the only thing I succeeded at doing was opening the game through terminal, and btw thanks for that, but now I wonder if there is a way I can open the game without it crashing so I can play it.

Share this post


Link to post
Share on other sites
34 minutes ago, binaryfail said:

Let's try something. Can you close all the programs that you're running with wine? I see TtT and a few other things in your screenshot.

Next, run the command "wineboot" in your terminal. Then try running the game again.

 

I ran wineboot in root and nothing happened so I continued with the command to open the game and this is what I got "http://prnt.sc/aj80ua"

Share this post


Link to post
Share on other sites
33 minutes ago, binaryfail said:

I just realized that your distro (Ubuntu?) doesn't have the JP locale installed. (I'm using another distro which did have it by default).

Can you run this command to install it?

 


sudo apt-get install language-pack-ja


 

This is the message I have received "http://prnt.sc/aj8815"

Share this post


Link to post
Share on other sites

Games that work under wine fall into four categories, in decreasing order of frequency:

1. Games that work with the existing game installer from scratch using wine either from CD or a cd image, or just copying the files across and then work fine. They may need you to use the installer to put all the files in the right place, or they may just have all the files in one place and where the files are kept doesn't matter so long as you access it directly.

2. Games that need to be installed on a real windows installation first, and then if you copy across the installed directory with all its files onto a linux partition you can just start the game up from that directory on linux.

3. Games that don't work at all under linux no matter how much you massage them but will work under a virtual machine running a real windows installation (such as kvm) on linux.

4. Games that won't work under linux no matter what you do, whether because they need the CD in place or due to some underlying hardware access on windows that can't be emulated on linux.

 

I have no idea what category your game falls under, but if it needs to use the full installer then just copying the files across will never get it working, or if it's one of the more difficult games to get working such as category 2+ then you need to put a lot of effort in to get it working in the first place. You've stated that others have gotten it working so I suspect what's missing in your case is you just copied the files and didn't use the actual installer.

 

In addition, as we've already pointed out, you need to have japanese language support installed along with suitable fonts (usually installing the language support brings the fonts in) and the japanese locale installed - how to do this depends on which flavour of linux you're using.

 

Finally, there are a number of things that won't work under plain wine by itself without adding a few windows support files, such as mpeg1 video. I suggest using winetricks to install them. Usually winetricks is installed along with wine but it may not be depending on the distribution in which case you can install it like this:

sudo apt-get install winetricks

Then you can install the windows support features necessary with winetricks like this:

winetricks corefonts d3dx9_36 devenum ffdshow quartz wmp9

When ffdshow is being installed, a configuration box comes up. When it does, don't just click okay but when it asks you what file types to play back, enable mpeg1 and mpeg2 which are disabled by default.

 

None of these are likely to fix your underlying problem though, which appears to be how you installed it in the first place, but at least your wine installation will be better equipped to handle anything from now on.

 

Finally as already described, virtually all Japanese VNs use the Japanese locale so you must start them with wine being told to use that locale

LC_ALL=ja_JP.UTF-8 wine programname.exe

is enough for that, replacing programname.exe with whatever the name of the program is you're trying to run. You have to cd into the directory where the program is.

Share this post


Link to post
Share on other sites
34 minutes ago, ittaku said:

Games that work under wine fall into four categories, in decreasing order of frequency:

1. Games that work with the existing game installer from scratch using wine either from CD or a cd image, or just copying the files across and then work fine. They may need you to use the installer to put all the files in the right place, or they may just have all the files in one place and where the files are kept doesn't matter so long as you access it directly.

2. Games that need to be installed on a real windows installation first, and then if you copy across the installed directory with all its files onto a linux partition you can just start the game up from that directory on linux.

3. Games that don't work at all under linux no matter how much you massage them but will work under a virtual machine running a real windows installation (such as kvm) on linux.

4. Games that won't work under linux no matter what you do, whether because they need the CD in place or due to some underlying hardware access on windows that can't be emulated on linux.

 

I have no idea what category your game falls under, but if it needs to use the full installer then just copying the files across will never get it working, or if it's one of the more difficult games to get working such as category 2+ then you need to put a lot of effort in to get it working in the first place. You've stated that others have gotten it working so I suspect what's missing in your case is you just copied the files and didn't use the actual installer.

 

In addition, as we've already pointed out, you need to have japanese language support installed along with suitable fonts (usually installing the language support brings the fonts in) and the japanese locale installed - how to do this depends on which flavour of linux you're using.

 

Finally, there are a number of things that won't work under plain wine by itself without adding a few windows support files, such as mpeg1 video. I suggest using winetricks to install them. Usually winetricks is installed along with wine but it may not be depending on the distribution in which case you can install it like this:


sudo apt-get install winetricks

Then you can install the windows support features necessary with winetricks like this:


winetricks corefonts d3dx9_36 devenum ffdshow quartz wmp9

When ffdshow is being installed, a configuration box comes up. When it does, don't just click okay but when it asks you what file types to play back, enable mpeg1 and mpeg2 which are disabled by default.

 

None of these are likely to fix your underlying problem though, which appears to be how you installed it in the first place, but at least your wine installation will be better equipped to handle anything from now on.

 

Finally as already described, virtually all Japanese VNs use the Japanese locale so you must start them with wine being told to use that locale

LC_ALL=ja_JP.UTF-8 wine programname.exe

is enough for that, replacing programname.exe with whatever the name of the program is you're trying to run. You have to cd into the directory where the program is.

I have done that but the game keeps crashing, maybe what I need to do is install a japanese locale, but it does say generation complete, but when I do the command locale -a there is no ja_JP.UTF-8, so I was wondering how to install it with my linux(Xubuntu)

Share this post


Link to post
Share on other sites
6 minutes ago, BLVCK said:

I have done that but the game keeps crashing, maybe what I need to do is install a japanese locale, but it does say generation complete, but when I do the command locale -a there is no ja_JP.UTF-8, so I was wondering how to install it with my linux(Xubuntu)

That is likely not your problem, but the way you installed it.

 

Either way, a quick google says
 

sudo locale-gen ja_JP

sudo locale-gen ja_JP.UTF-8

sudo update-locale

You probably need to log out and in again too.

Share this post


Link to post
Share on other sites
12 minutes ago, ittaku said:

That is likely not your problem, but the way you installed it.

 

Either way, a quick google says
 


sudo locale-gen ja_JP

sudo locale-gen ja_JP.UTF-8

sudo update-locale

You probably need to log out and in again too.

This is what it shows me "http://prnt.sc/ajl14u"

Share this post


Link to post
Share on other sites
6 minutes ago, BLVCK said:

This is what it shows me "http://prnt.sc/ajl14u"

Lulz. Okay this appears to be because you've chosen Xubuntu which is a stripped down Ubuntu so we probably have to do this the hard way.

sudo su
echo ja_JP.UTF8 UTF-8 >> /var/lib/locales/supported.d/local
dpkg-reconfigure locales
locale-gen ja_JP.UTF8
update-locale
exit

You may have to log out and in again for it to take effect.

Share this post


Link to post
Share on other sites
2 minutes ago, ittaku said:

Lulz. Okay this appears to be because you've chosen Xubuntu which is a stripped down Ubuntu so we probably have to do this the hard way.


sudo su
echo ja_JP.UTF8 UTF-8 >> /var/lib/locales/supported.d/local
dpkg-reconfigure locales
locale-gen ja_JP.UTF8
update-locale
exit

 

This is what I got before I did command exit "http://prnt.sc/ajlaq2" I can already see somethings are not going well. 

Share this post


Link to post
Share on other sites
17 minutes ago, ittaku said:

Yeah something's fucked up alright. Try reinstalling the japanese language support


sudo apt-get install --reinstall language-pack-ja

Plus I'm not sure if the package exists on ubuntu but it's worth a try:


sudo apt-get install locales-all

 

I guess I might not have hope at all .. :( "http://prnt.sc/ajll8h"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...